Segui o tutorial do MarioSAM para a criação do módulo autocompletar (http://mariosam.com.br/magento/modulo-auto-completar-endereco/), ao terminar tudo e digitar o CEP no input recebo um erro no console de que a página http://www.minhaloja.com.br/autocompletar/ajax/endereco não existe (404).

Segui exatamente como o tutorial diz, até copiei e colei ao invés de digitar, qual pode ser o problema? Estou usando um tema comprado, chama Bella Theme e estou usando onepage checkout.

Segui o tutorial do MarioSAM para a criação do módulo autocompletar (http://mariosam.com.br/magento/modulo-auto-completar-endereco/), ao terminar tudo e digitar o CEP no input recebo um erro no console de que a página http://www.minhaloja.com.br/autocompletar/ajax/endereco não existe (404). Segui exatamente como o tutorial diz, até copiei e colei ao invés de digitar, qual pode ser o problema? Estou usando um tema comprado, chama Bella Theme e estou usando onepage checkout.
 
0
reply

grande @lorranclickone

no post, eu falo para seguir exatamente o exemplo.. passo a passo... para ver tudo funcionando.. entao depois vc consegue aplicar no seu tema customizado, fazendo as adaptacoes necessarias.

se vc ja fez direto no tema customizado... entao vc nao seguiu conforme solicitado no post. smile

agora eu ja nao sei se o erro 404 esta relacionado ao seu tema, ou alguma configuracao, ou ate mesmo ao codigo.

entao, sugiro q faça esse teste... repita o processo usando o tema default do magento, para ver se funciona.

outro detalhe q pode influenciar no 404... eh q a url q vc usou como exemplo, esta amigavel (sem o index.php)... e isso precisa ser configurado la no backend do magento... se vc nao estiver usando reescrita de url (url amigavel)... entao esta dando erro, pq no seu link falta o /index.php antes do /autocompletar

sucesso ai.

grande @lorranclickone no post, eu falo para seguir exatamente o exemplo.. passo a passo... para ver tudo funcionando.. entao depois vc consegue aplicar no seu tema customizado, fazendo as adaptacoes necessarias. se vc ja fez direto no tema customizado... entao vc nao seguiu conforme solicitado no post. :) agora eu ja nao sei se o erro 404 esta relacionado ao seu tema, ou alguma configuracao, ou ate mesmo ao codigo. entao, sugiro q faça esse teste... repita o processo usando o tema default do magento, para ver se funciona. outro detalhe q pode influenciar no 404... eh q a url q vc usou como exemplo, esta amigavel (sem o index.php)... e isso precisa ser configurado la no backend do magento... se vc nao estiver usando reescrita de url (url amigavel)... entao esta dando erro, pq no seu link falta o /index.php antes do /autocompletar sucesso ai.

Master of Universe http://mariosam.com.br

 
0
reply

Vou testar novamente com essas novas dicas, posto feedback mais tarde.

abs

Vou testar novamente com essas novas dicas, posto feedback mais tarde. abs
 
0
reply
75
views
2
replies
2
followers
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft