Grande mestre Mario Sam,

Gostaria de uma ajuda sua e dos amigos do fórum, estou com uma dificuldade em identificar o arquivo e o local que posso inserir o código que o Mario postou sobre ocultar o preço e deixar a msg Preço Sob Consulta.

Já alterei o arquivo view.phtml e deu tudo certo, de boa, quando eu clico no produto na home ou pelo menu, ele me leva para página do produto e aparece a msg "preço sob consulta".

O meu problema é justamente o arquivo que você indica no tutorial, o list.phtml, eu já alterei o arquivo e nada acontece, quando clico no menu e vou escolher a categoria que se encontra o produto, ele aparece com a msg R$0,00 e mais embaixo uma exclamação dizendo sem estoque.

já utilizei o debug pra identificar qual é o arquivo certo e nada, tem um caminho que aponta para um arquivo hideprice/price.phtml, fiz a alteração lá também e não deu efeito algum.

Se realmente é o list,phtml que devo alterar, o arquivo que está no mesmo diretório do view.phtml, em qual parte do código preciso alterar?

Estou trabalhado com o template personalizado comprado na Forest Theme, o Harvest da empresa Templatemela

Agradeço a ajuda de todos, já estou a dois dias tentando resolver esse problema que aparentemente é fácil, mais estou com dificuldades.

Grato!

Grande mestre Mario Sam, Gostaria de uma ajuda sua e dos amigos do fórum, estou com uma dificuldade em identificar o arquivo e o local que posso inserir o código que o Mario postou sobre ocultar o preço e deixar a msg Preço Sob Consulta. Já alterei o arquivo view.phtml e deu tudo certo, de boa, quando eu clico no produto na home ou pelo menu, ele me leva para página do produto e aparece a msg "preço sob consulta". O meu problema é justamente o arquivo que você indica no tutorial, o list.phtml, eu já alterei o arquivo e nada acontece, quando clico no menu e vou escolher a categoria que se encontra o produto, ele aparece com a msg R$0,00 e mais embaixo uma exclamação dizendo sem estoque. já utilizei o debug pra identificar qual é o arquivo certo e nada, tem um caminho que aponta para um arquivo hideprice/price.phtml, fiz a alteração lá também e não deu efeito algum. Se realmente é o list,phtml que devo alterar, o arquivo que está no mesmo diretório do view.phtml, em qual parte do código preciso alterar? Estou trabalhado com o template personalizado comprado na Forest Theme, o Harvest da empresa Templatemela Agradeço a ajuda de todos, já estou a dois dias tentando resolver esse problema que aparentemente é fácil, mais estou com dificuldades. Grato!
 
0
reply

Olá pessoal, alguém poderia ajudar? ainda não consegui resolver o problema.

Olá pessoal, alguém poderia ajudar? ainda não consegui resolver o problema.
 
0
reply

grande @Rapahel

parece q faltou acertar apenas os detalhes ai. smile

seguinte.. se vc esta usando um tema comprado... verifique primeiro se este tema possui o list.phtml

pois sua alteracao devera acontecer neste arquivo...
se o tema nao possui o arquivo... entao ele sera carregado do proprio magento... e sua alteracao pode ser feita no arquivo original.. ou melhor ainda... ser feito uma copia dele para dentro do seu tema comprado, e alterar o phtml dentro do tema comprado.

considerando q vc acertou essa parte...
tem outro detalhe importante...
dentro do arquivo list.phtml.... existem dois blocos de codigo... um para carregar os produtos em modo List e outro em modo Grid.

vc provavelmente ajustou o codigo dentro do bloco List, mas sua pagina carrega em modo Grid... e faltou alterar tb essa parte do codigo.

para finalizar... garanta q limpou o cache do magento e do navegador.

sucesso ai.

grande @Rapahel parece q faltou acertar apenas os detalhes ai. :) seguinte.. se vc esta usando um tema comprado... verifique primeiro se este tema possui o list.phtml pois sua alteracao devera acontecer neste arquivo... se o tema nao possui o arquivo... entao ele sera carregado do proprio magento... e sua alteracao pode ser feita no arquivo original.. ou melhor ainda... ser feito uma copia dele para dentro do seu tema comprado, e alterar o phtml dentro do tema comprado. considerando q vc acertou essa parte... tem outro detalhe importante... dentro do arquivo list.phtml.... existem dois blocos de codigo... um para carregar os produtos em modo **List** e outro em modo **Grid**. vc provavelmente ajustou o codigo dentro do bloco List, mas sua pagina carrega em modo Grid... e faltou alterar tb essa parte do codigo. para finalizar... garanta q limpou o cache do magento e do navegador. sucesso ai.

Master of Universe http://mariosam.com.br

 
0
reply
63
views
2
replies
2
followers
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft