Boa tarde pessoal, sou novo no Magento e gostaria de uma ajuda, vou resumir o cenário:

Um conhecido pediu para eu mudar algumas coisas na loja dele que esta em faze de testes mais ele não tinha a senha do painel admin, então em alguns outros fóruns vi que se acessar o arquivos app\etc\local.xml la dentro tem os dados que estão se conectando no banco de dados, então mudei a senha do banco de dados e consegui acesso ao banco, porem ao acessar o painel admin ele acusa access denied para o usuario xxxx na pasta nas pastas do magento, acessando o ftp dei permissão em todas as pastas para todos. Voltei no arquivo local.xml e inserir a nova senha do usuário xxx e após isso o magento parou de dar erro mais passou a ir para a tela de instalação quando tento acessar. o banco de dados não tem nenhuma informação relevante mais o template ja estava configurado.

Minha pergunta, fazendo a reinstalação consigo jogar o template da forma que estava novamente no Magento?.

Desde já agradeço.

Boa tarde pessoal, sou novo no Magento e gostaria de uma ajuda, vou resumir o cenário: Um conhecido pediu para eu mudar algumas coisas na loja dele que esta em faze de testes mais ele não tinha a senha do painel admin, então em alguns outros fóruns vi que se acessar o arquivos app\etc\local.xml la dentro tem os dados que estão se conectando no banco de dados, então mudei a senha do banco de dados e consegui acesso ao banco, porem ao acessar o painel admin ele acusa access denied para o usuario xxxx na pasta nas pastas do magento, acessando o ftp dei permissão em todas as pastas para todos. Voltei no arquivo local.xml e inserir a nova senha do usuário xxx e após isso o magento parou de dar erro mais passou a ir para a tela de instalação quando tento acessar. o banco de dados não tem nenhuma informação relevante mais o template ja estava configurado. Minha pergunta, fazendo a reinstalação consigo jogar o template da forma que estava novamente no Magento?. Desde já agradeço.
 
0
reply

fala @ronys00

parece q vc confundiu as senhas ai brother.
senha de acesso ao banco de dados, eh uma coisa...
senha para acessar o sistema, q fica armazenado no banco de dados, eh outra coisa. smile

para alterar a senha do admin: http://mariosam.com.br/magento/senha-admin/

para alterar a senha do banco: http://mariosam.com.br/magento/alterar-instalacao/

qualquer coisa q vc altere fora do planejado, vai acontecer tudo isso q vc comentou acima.

sobre sua ultima pergunta... se vc reinstalar tudo, consegue jogar o template do jeito q estava?? nao...

ah nao ser q vc use exatamente a mesma base de dados... e o magento reconheça as tabelas, e resolva nao sobreescrever os dados (q pode acontecer)... assim ele vai manter as configuracoes do seu template.

qualquer coisa diferente disso... ele vai instalar o template com configuracao padrao, de fabrica.

sucesso ai.

fala @ronys00 parece q vc confundiu as senhas ai brother. senha de acesso ao banco de dados, eh uma coisa... senha para acessar o sistema, q fica armazenado no banco de dados, eh outra coisa. :) para alterar a senha do admin: http://mariosam.com.br/magento/senha-admin/ para alterar a senha do banco: http://mariosam.com.br/magento/alterar-instalacao/ qualquer coisa q vc altere fora do planejado, vai acontecer tudo isso q vc comentou acima. sobre sua ultima pergunta... se vc reinstalar tudo, consegue jogar o template do jeito q estava?? nao... ah nao ser q vc use exatamente a mesma base de dados... e o magento reconheça as tabelas, e resolva nao sobreescrever os dados (q pode acontecer)... assim ele vai manter as configuracoes do seu template. qualquer coisa diferente disso... ele vai instalar o template com configuracao padrao, de fabrica. sucesso ai.

Master of Universe http://mariosam.com.br

 
0
reply

Mario SAM, obrigado pela luz...

Existe alguma forma de eu recuperar o acesso a minha loja, pois após essa minha “lambança" quando entro ele já vai direto para a tela dr instalação. Tem como eu retomar a loja sem fazer essa instalação? Outra pergunta se eu instalar em um novo banco de dados e após apontar o magento para o banco antigo ele vai ler o que ja estava lá (template, dados, etc...)?

Obrigado
Rony

Mario SAM, obrigado pela luz... Existe alguma forma de eu recuperar o acesso a minha loja, pois após essa minha “lambança" quando entro ele já vai direto para a tela dr instalação. Tem como eu retomar a loja sem fazer essa instalação? Outra pergunta se eu instalar em um novo banco de dados e após apontar o magento para o banco antigo ele vai ler o que ja estava lá (template, dados, etc...)? Obrigado Rony
edited Jun 16 at 3:50 am
 
0
reply

fala @ronys00
vc esta tentando o caminho mais dificil brother. hehe

se vc instalar novamente, vai ter duas bases de dados, e depois vai apontar para a base antiga...

sendo q... vc soh precisa apontar para a base antiga agora... nao precisa instalar novamente para isso.

ele esta indo para a tela de instalacao do magento, justamente pq vc modificou o arquivo XML da instalacao, e agora ele nao encontra mais a base de dados... por isso pede para instalar.

entao vc soh precisa pegar seu backup do XML, e sobrepor o arquivo.

se nao fez backup.. comece a fazer backup sempre... e vai ser preciso abrir o arquivo XML novamente, e colocar todos os dados antigos... banco, user, senha... tudo como estava originalmente.

sucesso ai.

fala @ronys00 vc esta tentando o caminho mais dificil brother. hehe se vc instalar novamente, vai ter duas bases de dados, e depois vai apontar para a base antiga... sendo q... vc soh precisa apontar para a base antiga agora... nao precisa instalar novamente para isso. ele esta indo para a tela de instalacao do magento, justamente pq vc modificou o arquivo XML da instalacao, e agora ele nao encontra mais a base de dados... por isso pede para instalar. entao vc soh precisa pegar seu backup do XML, e sobrepor o arquivo. se nao fez backup.. comece a fazer backup sempre... e vai ser preciso abrir o arquivo XML novamente, e colocar todos os dados antigos... banco, user, senha... tudo como estava originalmente. sucesso ai.

Master of Universe http://mariosam.com.br

 
0
reply

@mariosam Mais uma vez obrigado por me responder.

Na tela de instalação apontei para o banco existente com os dados que acesso o PHPAdmin porém ele da erro de conexão com o banco, outra coisa a estrutura de pastas está toda na pasta public_html do meu provedor, na tela de instalação aponto para www.xxxxx.com.br/public_html, ou localhost/public_html e ele tbm reclama que a url é inválida, quando não reclama isso reclama conexão com o banco mesmo eu conseguindo acessar o banco no PHP Admin. Sabe o que pode estar acontecendo?

Desde já agradeço.
Rony

@mariosam Mais uma vez obrigado por me responder. Na tela de instalação apontei para o banco existente com os dados que acesso o PHPAdmin porém ele da erro de conexão com o banco, outra coisa a estrutura de pastas está toda na pasta public_html do meu provedor, na tela de instalação aponto para www.xxxxx.com.br/public_html, ou localhost/public_html e ele tbm reclama que a url é inválida, quando não reclama isso reclama conexão com o banco mesmo eu conseguindo acessar o banco no PHP Admin. Sabe o que pode estar acontecendo? Desde já agradeço. Rony
edited Jun 16 at 3:12 pm
 
0
reply

fala @ronys00

entao...
quando vc aluga um servidor de hospedagem...
ele eh uma maquina fisica... um computador mesmo.. com sistema operacional... muito semelhante aos desktops q temos em casa.

isso significa q... essa maquina possui diretorios e arquivos...
e cada cliente q aluga um espaço no servidor, tem seu diretorio.

entao a sua pasta public_html
fica por exemplo em c:\apache\ronys00\www\public_html

e vc configurou seu dominio para este servidor... algo como www.sualoja.com.br

entao, sempre q alguem digitar www.sualoja.com.br, vai cair diretamente em c:\apache\ronys00\www\public_html

isso inclui vc mesmo!!! ou seja... quando vc digitar www.sualoja.com.br para fazer a instalacao do magento... vc NAO PRECISA digitar public_html... pois esse caminho eh oculto dentro da sua url... vc soh sabe q ele existe, pq vc eh o administrador.

o mesmo vale para o exemplo em localhost... sendo q localhost vc vai usar apenas no seu desktop.. o computador q vc tem em casa... e q nao precisa estar conectado a internet.

se vc ja tinha o magento instalado no servidor... vc nao precisa instalar novamente... mesmo q ele leve vc para a tela de instalacao... ele soh faz isso pq seu arquivo de configuracao com banco esta invalido...

basta arrumar o arquivo como eu citei acima... e essa tela vai sumir, e sua instalacao voltara ao normal.

sucesso ai.

fala @ronys00 entao... quando vc aluga um servidor de hospedagem... ele eh uma maquina fisica... um computador mesmo.. com sistema operacional... muito semelhante aos desktops q temos em casa. isso significa q... essa maquina possui diretorios e arquivos... e cada cliente q aluga um espaço no servidor, tem seu diretorio. entao a sua pasta public_html fica por exemplo em **c:\apache\ronys00\www\public_html** e vc configurou seu dominio para este servidor... algo como **www.sualoja.com.br** entao, sempre q alguem digitar **www.sualoja.com.br**, vai cair diretamente em **c:\apache\ronys00\www\public_html** isso inclui vc mesmo!!! ou seja... quando vc digitar www.sualoja.com.br para fazer a instalacao do magento... vc NAO PRECISA digitar public_html... pois esse caminho eh oculto dentro da sua url... vc soh sabe q ele existe, pq vc eh o administrador. o mesmo vale para o exemplo em localhost... sendo q localhost vc vai usar apenas no seu desktop.. o computador q vc tem em casa... e q nao precisa estar conectado a internet. se vc ja tinha o magento instalado no servidor... vc nao precisa instalar novamente... mesmo q ele leve vc para a tela de instalacao... ele soh faz isso pq seu arquivo de configuracao com banco esta invalido... basta arrumar o arquivo como eu citei acima... e essa tela vai sumir, e sua instalacao voltara ao normal. sucesso ai.

Master of Universe http://mariosam.com.br

 
0
reply

@mariosam Mais uma vez obrigado por me responder.

Na tela de instalação apontei para o banco existente com os dados que acesso o PHPAdmin porém ele da erro de conexão com o banco, outra coisa a estrutura de pastas está toda na pasta public_html do meu provedor, na tela de instalação aponto para www.xxxxx.com.br/public_html, ou localhost/public_html e ele tbm reclama que a url é inválida, quando não reclama isso reclama conexão com o banco mesmo eu conseguindo acessar o banco no PHP Admin. Sabe o que pode estar acontecendo?

Desde já agradeço.
Rony

@mariosam Obrigado pelo retorno... Graças a Deus o servidor tinha backup, então restaurei a estrutura para antes de eu ter bugado, o cliente lembrou que tinha a senha do admin e me passou e tudo voltou ao normal... Obrigado pela paciência e orientações.

Abraços
Rony

>@mariosam Mais uma vez obrigado por me responder. >Na tela de instalação apontei para o banco existente com os dados que acesso o PHPAdmin porém ele da erro de conexão com o banco, outra coisa a estrutura de pastas está toda na pasta public_html do meu provedor, na tela de instalação aponto para www.xxxxx.com.br/public_html, ou localhost/public_html e ele tbm reclama que a url é inválida, quando não reclama isso reclama conexão com o banco mesmo eu conseguindo acessar o banco no PHP Admin. Sabe o que pode estar acontecendo? >Desde já agradeço. >Rony @mariosam Obrigado pelo retorno... Graças a Deus o servidor tinha backup, então restaurei a estrutura para antes de eu ter bugado, o cliente lembrou que tinha a senha do admin e me passou e tudo voltou ao normal... Obrigado pela paciência e orientações. Abraços Rony
 
0
reply
76
views
6
replies
2
followers
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft